home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / sys-libs / pwdb-0.62 / pwdb-0.62.ebuild < prev    next >
Text File  |  2005-10-13  |  2KB  |  68 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/sys-libs/pwdb/pwdb-0.62.ebuild,v 1.21 2005/10/08 12:50:35 blubb Exp $
  4.  
  5. inherit eutils flag-o-matic
  6.  
  7. DESCRIPTION="Password database"
  8. HOMEPAGE="http://packages.gentoo.org/ebuilds/?pwdb-${PVR}"
  9. SRC_URI="mirror://gentoo/${P}.tar.gz"
  10.  
  11. LICENSE="|| ( BSD GPL-2 )"
  12. SLOT="0"
  13. KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
  14. IUSE="selinux"
  15.  
  16. DEPEND="virtual/libc
  17.     selinux? ( sys-libs/libselinux )"
  18.  
  19. src_unpack () {
  20.     unpack ${A}
  21.  
  22.     cd ${S}
  23.     # Uses gcc as linker needed for hppa, but good idea in general.
  24.     epatch ${FILESDIR}/${P}-use-gcc-as-linker.patch
  25.  
  26.     use selinux && epatch ${FILESDIR}/${P}-selinux.patch
  27.  
  28.     sed -i \
  29.         -e "s/^DIRS = .*/DIRS = libpwdb/" \
  30.         -e "s:EXTRAS += :EXTRAS += ${CFLAGS} :" \
  31.         Makefile
  32.     sed -i -e "s/=gcc/=$(tc-getCC)/g" default.defs
  33. }
  34.  
  35. src_compile() {
  36.     filter-flags -fstack-protector
  37.  
  38.     # author has specified application to be compiled with `-g` 
  39.     # no problem, but with ccc `-g` disables optimisation to make
  40.     # debugging easier, `-g3` enables debugging and optimisation
  41.     [ "${ARCH}" = "alpha" -a "${CC}" = "ccc" ] && append-flags -g3
  42.  
  43.     emake || die
  44. }
  45.  
  46. src_install() {
  47.     dodir /$(get_libdir) /usr/$(get_libdir) /usr/include/pwdb
  48.     make \
  49.         INCLUDED=${D}/usr/include/pwdb \
  50.         LIBDIR=${D}/$(get_libdir) \
  51.         LDCONFIG="echo" \
  52.         install || die
  53.  
  54.     preplib /
  55.     mv ${D}/$(get_libdir)/*.a ${D}/usr/$(get_libdir)
  56.  
  57.     # See bug #4411 for more info
  58.     gen_usr_ldscript libpwdb.so
  59.  
  60.     insinto /etc
  61.     doins conf/pwdb.conf
  62.  
  63.     dodoc CHANGES CREDITS README
  64.     dohtml -r doc
  65.     docinto txt
  66.     dodoc doc/*.txt
  67. }
  68.